Search found 9 matches

by surfrider
01 May 2021 05:12
Forum: CPP4ROBOTS
Topic: Timer Example
Replies: 4
Views: 1616

Re: Timer Example

Most software I have work on, when you create a thread or have a while loop it is always advised to have at least a very short sleep so the OS can to task switching during the sleep.
It depends a bit on the multi-threading system of the EV3 or cpp4robots.
by surfrider
13 Apr 2021 20:35
Forum: CPP4ROBOTS
Topic: Reading Raw Gyro data
Replies: 1
Views: 966

Reading Raw Gyro data

I hope to get more accurate gyro angles. With Labview Mindstorms you can do a raw reading to get a value between 0 and 4095 instead of 0 and 360 degrees. I would like to use GetData_UART to read the raw gyro data, hopefully get a higher resolution. But I don't know what kind of data is read via GetD...
by surfrider
04 Mar 2021 22:14
Forum: CPP4ROBOTS
Topic: Feature request: connected motor/sensor detection
Replies: 1
Views: 921

Feature request: connected motor/sensor detection

I'm trying to make a bit of test software for calibrating my robot. It works with a fixed set of sensors and motors, but I would love to be able to make it more generic so it would always work. But for this I need a way the retrieve the connected motors and sensors, and for each the type it is. Woul...
by surfrider
18 Feb 2021 16:02
Forum: CPP4ROBOTS
Topic: Timer Example
Replies: 4
Views: 1616

Re: Timer Example

Is it needed/advised to put a sleep in the while loop? To prevent 100% CPU load?
by surfrider
10 Feb 2021 08:21
Forum: CPP4ROBOTS
Topic: Motor Busy with 2 motors not working?
Replies: 3
Views: 462

Re: Motor Busy with 2 motors not working?

No problem, very happen with the current version, I can make workarounds for now.

What is your prefered way to report possible bugs?
This Forum?
Do you want one topic with bug reports? Or a topic per bug?
by surfrider
09 Feb 2021 21:59
Forum: CPP4ROBOTS
Topic: Motor Busy with 2 motors not working?
Replies: 3
Views: 462

Motor Busy with 2 motors not working?

Now I got cpp4Robots work, first many thanks for this, really love it! I'm using two motors to drive my robot. Is there a bug? If I call isMotorBusy(E_Port_BC, E_MotorType_Large) while the robot is driving, the call returns false. while: isMotorBusy(E_Port_B, E_MotorType_Large) || isMotorBusy(E_Port...
by surfrider
19 Jan 2021 20:52
Forum: CPP4ROBOTS
Topic: VS 2019 Project Template not found
Replies: 5
Views: 593

Re: VS 2019 Project Template not found

Item 1 might be the problem. The Template Zip file is is C:\<User>\Documents .... folder as you have written. But that is not the location of the "my documents" folder. I think your installer does not use the "my documents" folder location but is hard coded to the standard my doc...
by surfrider
19 Jan 2021 10:31
Forum: CPP4ROBOTS
Topic: VS 2019 Project Template not found
Replies: 5
Views: 593

Re: VS 2019 Project Template not found

Yes, "Desktop development with C++" is installed. Both that is the online installed workload.

Maybe one of the others is needed?
by surfrider
18 Jan 2021 17:07
Forum: CPP4ROBOTS
Topic: VS 2019 Project Template not found
Replies: 5
Views: 593

VS 2019 Project Template not found

In stalled Visual Studio 2019 with the Cpp4Robots extension.
Toolbar is visible, I can open the example projects in the Program Files folder.
But when I try to create a new project, the Project Template is not found.

Any ideas?